7th April 2020

Emails delayed when forwarding to Google addresses

-- UPDATE 13/04/2020 --

We're closing this incident at this time as resolved at this time. If you continue to have issues with delayed emails, please contact our support team for further assistance.


-- UPDATE 08/04/2020 --

At the moment we believe that this has been resolved, but we're still actively monitoring the delivery of forwarded emails and will update this issue accordingly.


Currently we are investigating delayed email delivery when forwarding to Google addresses (@gmail.com, @google.com, etc).

The delay is related to outgoing email filtering and we're to continue tracking these and find a solution as soon as possible.

Updates will be posted here regarding the status of the issue. Thank you for your patience and cooperation.