20th April 2020

Web Hosting HP 109 - Emergency Maintenance

-- UPDATE 01:15 AM EST --

Emergency maintenance has been completed on HP109, and the server has been rebooted successfully. All functionality should now be restored. Thank you for your patience and please do reach out to our Support team should you require further assistance, or have any additional concerns.


Our server health team is investigating an issue affecting one of our server, HP109. The server has been taken down for an emergency maintenance. Websites & Emails hosted in the server will be inaccessible in the meantime.

Updates will be posted here as we received more information. We sincerely apologize for the inconveniences caused.