15th May 2020

Advanced Email Basic/Advanced Email Connectivity

Update 04:43 PM EST

The issue with basic/advanced email is solved.

Thank you for your patience.


Update 02:05 PM EST

Our team is continuing to work on the issue. Services are beginning to recover and fewer users are currently being impacted.

It was recommended by our server engineers to users not use the reindex feature during the degraded performance window.

We apologize for the inconvenience and will share updates here as they are made available.


Update 11:35 AM EST

Customers may experience downtime when interfacing with webmail or other email client protocols.

We apologize for the inconvenience and will share updates here as they are made available.


INVESTIGATING: 10:30 AM EST

A small set of users may experience the inability to connect to our Basic/Advanced email platform at this time.

Our server engineers are investigating the issue, and we will post further updates here as we receive them.