18th May 2020

Advanced Email Basic/Advanced Email Webmail Login Timeout

RESOLVED: 10:40 PM EST

The issue with basic/advanced email is solved.

We apologize for the inconvenience and thank you for your patience.


INVESTIGATING: 08:30 PM EST

A small set of users may experience slowness or time outs while attempting to connect to our Basic/Advanced email platform/webmail at this time.

Our server engineers are investigating the issue, and we will post further updates here as we receive them.