26th May 2020

Basic Email Basic/Advanced Inbound/Outbound Mail Issue

RESOLVED - 8:25 AM EST

All impacted nodes are now operational and there is no further delivery delay.


INVESTIGATING - 8:05 AM EST

Currently, we are investigating an issue regarding inbound and outbound mail for our Basic and Advanced email service. We have engaged the operations team to investigate the issue.

Impact: Inbound and outbound emails will be queued until the nodes are being recovered.