27th May 2020

Advanced Email Basic/Advanced Inbound/Outbound Mail Issue

RESOLVED 10:20 PM EST

This issue is now resolved and all services are now operational.

Thank you for your patience.


INVESTIGATING - 9:35 PM EST

Currently, we are investigating an issue regarding inbound and outbound mail for our Basic and Advanced email service. We have engaged the operations team to investigate the issue.

Impact: Some users may experience issues sending and receiving mail at this time.

Sorry for the inconvenience. We will provide more updates as they become available.