18th June 2020

Advanced Email Basic/Advanced Email Webmail Login Error

RESOLVED 19:50 PM EST

Our server engineers were able to identify and reboot the affected mailstores to bring services back online. This issue is now resolved and all services are now operational.

We are sorry for the inconvenience and we appreciate your patience in this matter.


INVESTIGATING

A small set of users may experience slowness or time-outs while attempting to connect to our Basic/Advanced email platform/webmail at this time.

Our server engineers are investigating the issue, and we will post further updates here as we receive them.