27th July 2020

Phone Support System Phone Support Temporarily Unavailable

RESOLVED: July 28, 2020 02:21 AM EST

Our phone systems are back online but we are still monitoring it. You should be able to reach us through a Phone call aside from Live Chat and Emails. We're sorry again for the inconvenience during the downtime.


INVESTIGATING 11:25 PM EST

Our phone support system is currently unavailable. You may be able to call the number, however, we can not answer at this time due to internal network issues.

This is being investigated at this time by our internal team.

We're sorry for the inconvenience this may be causing. For urgent matters please contact our LiveChat support via https://www.hostpapa.com or https://www.lunarpages.com or follow up on existing support tickets directly.

Once we have an update on the situation we will post it here. Sorry for the inconvenience.