28th August 2020

Database Scheduled Maintenance, scheduled 3 weeks ago

COMPLETED 02:55 AM EST

The Database Maintenance has been completed. Access to the Hostpapa dashboard has been restored and will also be able to place new orders.

We thank you for your patience and apologize for any inconvenience that this may cause.


UPDATE 01:00 AM EST

Our Database maintenance is currently ongoing. During this time, clients might not be able to access their HostPapa Dashboard and will be unable to place orders as well.

Please be assured that there will be no impact on customers’ websites, databases, or email accounts; the maintenance is only on our own systems.

Our telephone systems and the online chat will remain operational during this period. We will also be posting updates once completed.

We thank you for your patience and apologize for any inconvenience that this may cause.


We are performing maintenance for our database on Aug/29/2020 at 01:00 AM EST. During this time, clients might not be able to access their HostPapa Dashboard and will be unable to place orders as well.

The maintenance will take 4 hours and the expected completion time is at 05:00 AM EST. We will be posting updates once completed.

Sorry for the inconvenience and thank you for your patience.