31st August 2020

Protection Power Scheduled Maintenance, scheduled 3 weeks ago

COMPLETED 05:00 AM EST

Protection Power maintenance has been completed.

We are sorry for the inconvenience that this might cause you and we appreciate your patience in this matter.


UPDATE 03:00 AM EST

Scheduled maintenance for Protection Power service is in p progress. The expected completion time is at 05:00 AM EST.

During this maintenance window, you might not be able to login to your Protection Power portals however, there will be no downtime on your websites and your website protections, and scans will continue as is.

This time will be used to speed up our overall services and increase infrastructure stability.

Updates will be posted once made available.

We are sorry for the inconvenience that this might cause you and we appreciate your patience in this matter.


We will be performing maintenance with our Protection Power service on September 01, 2020, at 03:00 AM EST and there will be an expected downtime of 2 hours.

During this maintenance window, you might not be able to login to your Protection Power portals however, there will be no downtime on your websites and your website protections, and scans will continue as is.

This time will be used to speed up our overall services and increase infrastructure stability.

Updates will be posted once made available.

We are sorry for the inconvenience that this might caused you and we appreciate your patience in this matter.