3rd September 2020

Basic/Advanced Email Scheduled Maintenance, scheduled 2 weeks ago

COMPLETED 03:00 AM EST

The scheduled maintenance has been completed.

We apologize for any inconvenience that this may have causes you and we thank you for your patience in this matter.


UPDATE: 12:00 AM EST

Scheduled maintenance is currently in progress. We will provide updates as necessary.

Client Impact: IMAP and POP users will experience service interruption for a short duration during the maintenance. Users will be able to send and receive emails during the maintenance period.

Estimated completion time: 03:00 AM EST

We apologize for any inconvenience that this may cause you and we thank you for your patience in this matter.


The engineering team will be performing a code deployment to address issues where Email Quotas are not updating to their accurate amount.

Client Impact: IMAP and POP users will experience service interruption for a short duration during the maintenance. Users will be able to send and receive emails during the maintenance period.

Estimated duration: 3 hours