15th September 2020

Email bounceback messages

RESOLVED 08:00 PM EST

Our Server Admins have implemented the fix, and this issue should be resolved.

If you are still experiencing issues with your emails, feel free to contact our support channels through phone or chat so we can further assist you.

We apologize for any inconvenience that this has caused you.


UPDATE: 5:00 PM EST

The cause of the issue was already identified and our team is still working to solve the bounceback issue. Thank you for your patience.

More updates will be posted here.


UPDATE: 2:30 PM EST

Our server health team is still working to solve the bounceback issue. Thank you for your patience.

More updates will be posted here.


Our server health team is currently investigating bounceback email issues, and we are working to resolve this issue as quickly as possible. Thank you for your patience and cooperation in regard to troubleshooting this issue.

More updates will be posted here.