8th October 2020

VPS Hosting VPS websites connectivity issues

RESOLVED 07:30 PM EST

Our Server Admins fixed the issue with the affected servers and all services should be back up and running at this time. If you are still experiencing issues with your services, please reach our Support team through phone, email, or live chat.

We sincerely apologize for the inconvenience caused.


UPDATE: 5:00 PM EST

Our server health team is still working to solve the websites' not loading issue. Thank you for your patience.

More updates will be posted here.


Our server health team is currently investigating connectivity issues related to websites hosted in VPS servers. Clients may notice latency in requests or site not loading errors intermittently. We will provide further updates via this status page as they are made available.

Thank you for your patience and understanding while it's being resolved. We sincerely apologize for the inconvenience caused.