26th October 2020

Web Hosting HP140 Outage - Server Offline - Intermittent Connectivity

FIXED: 07:10 AM EST

The server health team has restored the services to HP140 and it is functioning normally at this time.

If you continue to experience any issues, please contact our support team.

SERVER DOWN: 05:50 AM EST

Server HP140 is experiencing issues at this time and remains offline. Websites and email accounts hosted here will experience connectivity issues at this time.

Our server health team is aware and working on the issue to have it resolved as quickly as possible.

Updates on the issue will be posted here, thank you for your patience and cooperation.