18th December 2020

Web Hosting Slowness due to high server load issue - HP262, HP302, HP305, HP308, HP310

FIXED: 12/22/2020 08:20 AM EST

A fix has been applied to return server load to normal.

Should you continue to experience issues, please contact our support team via LiveChat, Phone or Email/Support Ticket.


UPDATE: 08:20 AM EST

Normal functionality has been returned to servers HP303, HP255 and HP269. They will continue to be monitored while work continues on the remaining affected servers.

Further updates will be posted here. Thank you for your patience.


UPDATE: 12/21/2020 08:30 AM EST

Multiple servers (HP255, HP269, HP262. HP302, HP303, HP305, HP308, HP310) are affected by the high load issues. Our server health team is aware and continues to work to resolve the issue as quickly as possible.

Thank you for your patience and cooperation in regards to troubleshooting this issue.


INVESTIGATING: 03:00 PM EST

HP302, HP303, HP305, HP308, HP310 are experiencing high load issues that may affect the ability for clients to access services/accounts on that server.

This has been identified by our server health team, and they are working to resolve the issue as soon as possible.

Thank you for your patience and cooperation in regard to troubleshooting this issue. We will post further updates on this page, until the issue is resolved.