8th July 2021

Basic Email Basic/Advanced Inbound delays

FIXED 01:40 PM EST

This issue is now resolved, and all services are now operational.

Thank you for your patience.


INVESTIGATING - 1:00 PM EST

We are investigating an issue regarding inbound delays for our Basic and Advanced email service.

Sorry for the inconvenience. We will provide more updates as they become available.