30th July 2021

VPS Hosting Email bounceback from Spamrl.com

COMPLETE: July/30/2021 07:00 PM EST

The issue has been resolved and the emails are operating normally again at this time.

Should you continue to have any issues, please contact our support team via LiveChat, Phone, or Email/Support Ticket. You can find all our contact info at https://hostpapa.com/about-hostpapa/contact.


UPDATE: July/30/2021 05:20 AM EST

Our team continues to investigate the issue, however, a workaround is to have your IP address whitelisted here: https://spamrl.com/delist/

If you need assistance with this, please contact our support team.

We appreciate your continued patience while the issue is being resolved.


INVESTIGATING: July/30/2021 12:30 AM EST

A small number of clients are experiencing issues where emails are receiving a bounce back error from spamrl.com.

Our Server engineers are investigating this and further updates will be posted here.

We appreciate your patience while the issue is being investigated.