19th August 2021

Web Hosting HP262 Performance Issues

FIXED: Aug/19/2021 02:00 PM EST

The issue has been resolved and HP262 is operating normally at this time.

Should you continue to have any issues, please contact our support team via LiveChat, Phone or Email/Support Ticket. You can find all our contact info at www.hostpapa.com .


INVESTIGATING: Aug/19/2021 10:00 AM EST

HP262 is experiencing performance issues. Websites hosted here may be slower to load.

Our server health team is aware and investigating the issue.

Further updates will be posted here. Thank you for your patience while the issue is being resolved.