16th September 2021

Phone Support System Voice Support issue

FIXED Sep/16/2021 1:15 pm

The issue has been resolved. Thank you for the patience.


INVESTIGATING Sep/16/2021 1:00 PM

We have identified an issue with our voice support phone lines that are affecting incoming and outgoing calls for 905 XXX. You may not be able to contact us via phone.

This is being investigated, and we will update this status page periodically until resolved.

We're sorry for the inconvenience. You can still contact support via the Toll Free system, our ticket system, by email, and via LiveChat support at our website (https://www.hostpapa.com).