20th September 2021

Phone Support System Phone Systems Issue

FIXED Sep/20/2021 12:30 PM EST

The issue has been resolved. Thank you for the patience.


INVESTIGATING Sep/20/2021 11:00 AM EST

We have identified an issue with our voice support phone lines. You may not be able to contact us via phone.

This is being investigated, and we will update this status page periodically until resolved.

We're sorry for the inconvenience. You can still contact support via the Toll Free system, our ticket system, by email, and via LiveChat support at our website (https://www.hostpapa.com).