12th July 2019

Phone Support System Intermittent issues - phone support system

Update:

The system is now fully operational.

Thank you for your patience and understanding on this matter!

============================================================================

Update:

The issue is now fixed. We are still monitoring it to ensure the system resumed all its functionalities.

Thank you for your patience and understanding on this matter!

============================================================================

We are currently experiencing issues with the system used for phone support. Our team is investigating the issue at this moment.

Meantime we invite our customers to contact us via Live Chat or by submitting a support ticket.

We are sorry for the inconvenience caused!