30th September 2021

Web Hosting Shared hosting - Expired SSL Warnings/Caching issue

UPDATE: Oct/01/2021 07:50 AM EST

Our Systems team has applied a fix on the server-side which resolved the errors related to the expired Let's Encrypt SSL Certificates for Email Clients and Browsers but there will still be some that might still encounter an error that will require 24h to be updated.

Thank you for your patience and cooperation in regard to resolving this issue.


UPDATE: Oct/01/2021 12:15 AM EST

Our Systems team has applied a fix on the server-side which will help to mitigate the errors related to the expired Let's Encrypt SSL Certificates for Email Clients and Browsers but there will still be some that might still encounter an error. Our team is still working on the issue until it is fully resolved.

We will provide further updates once they are made available.

We apologize for the inconvenience and thank you for your patience and cooperation as we work towards resolving these issues.


UPDATE: Sep/30/2021 2:00 PM EST

Our Systems team is currently investigating issues with cached expired Let's Encrypt SSL certificates for Email Clients and Browsers. Yesterday Let's Encrypt's SSL Root certificate expired globally and although it was replaced there are lingering caching issues on devices that are still seeing the expired certificates. This is affecting some websites loading over HTTPS, as well as connections over Email using SSL ports.

We will continue to post further updates here.

Thank you for your patience and cooperation as we work towards resolving these issues.


INVESTIGATING: Sep/30/2021 12:00 PM EST

There are caching issues from the expired SSL certificate still seeing it as expired, even after replacement, that is impacting our shared hosting. This caching issue is being investigated, and we thank you for your patience.

Further updates will be posted here.

Thank you for your patience and cooperation in regard to resolving this issue.