19th October 2021

Basic Email Papamail experiencing some emails issues

FIXED: Oct/19/2021 03:10 PM EST

Our Engineering team has fixed the issues. If you are still experiencing issues with your papamail accounts, please contact our Support team through Live Chat, Phone, or Email [email protected]

Thank you for your patience in this matter.


INVESTIGATING: Oct/19/2021 01:40 PM EST

We are experiencing a degradation in service for mail.papamail.net. Users may experience issues with sending with error "SMTP Error (454)" Authentication failed". Our Engineering team has been engaged, and they are currently investigating the issue.

Thank you for your patience and understanding while it's being resolved. We sincerely apologize for the inconvenience caused.