21st October 2021

VPS Hosting VPS connectivity issues

FIXED: Oct/21/2021 10:15 PM EST

Our Server Admins have fixed the issue and VPS accounts should now be accessible. If you are still experiencing issues with your account access, website, emails, etc., please contact our Support team through Live Chat, Phone, or Email [email protected]

Thank you for your patience in this matter.


INVESTIGATING: Oct/21/202109:35 PM EST

Our server health team is currently investigating connectivity issues related to websites hosted in VPS servers. Clients may notice latency in requests or site not loading errors. We will provide further updates via this status page as they are made available.

Thank you for your patience and understanding while it's being resolved. We sincerely apologize for the inconvenience caused.