28th October 2021

Basic Email Papamail connectivity issues

FIXED: Oct/29/2021 12:06 AM EST

Our Engineering team has deployed a fix and services should be accessible again. If you are still experiencing issues with your papamail accounts, please contact our Support team through Live Chat, Phone, or Email [email protected]

Thank you for your patience and understanding in this matter.

==================================

INVESTIGATING: Oct/28/2021 11:40 PM EST

We are experiencing a degradation in service for mail.papamail.net. Users may experience issues with receiving, sending, and logging in to the Webmail portal. We will provide updates as they are made available.

We sincerely apologize for the inconvenience caused. We appreciate your patience and understanding while it is being resolved.