4th November 2021

Basic Email Papamail connectivity issues

FIXED: Nov/04/2021 06:40 AM EST

Our Engineering team has deployed a fix and services should be accessible again. If you are still experiencing issues with your papamail accounts, please contact our Support team through Live Chat, Phone, or Email [email protected]

Thank you for your patience and understanding in this matter.

==================================

INVESTIGATING: Nov/04/2021 06:00 AM EST

We are currently experiencing an issue hosted email affecting mail.papamail.net SMTP. Our engineering team is aware and currently investigating the issue. We will provide an update as soon as we have more information. We thank you for your patience.