4th November 2021

Basic Email Papamail connectivity issues

FIXED: Nov/04/2021 10:25 AM EST

Our Engineering team has deployed a fix and services should be accessible again. If you are still experiencing issues with your papamail accounts, please contact our Support team through Live Chat, Phone, or Email [email protected]

Thank you for your patience and understanding in this matter.

==================================

INVESTIGATING: Nov/04/2021 10:10 AM EST We are investigating an issue preventing some users on mail.papamail.net from logging into Webmail. Our engineering team has been engaged.

We will provide an update once we have additional information.