4th November 2021

Web Hosting Server Load Issues

MONITORING: Nov/04/2021 11:50 PM EST

Our Server Health team has applied a fixed and the server load is now stable again. We are still it to ensure stability. If you are still experiencing any errors with your services, please contact our Support team through Live Chat, Phone, or Email [email protected]

Thank you for your patience and understanding in this matter.

====================================

INVESTIGATING: Nov/04/2021 10:20 PM EST

We are experiencing multiple server high load issues that may affect the ability of clients to access websites and email on the server.

This is being investigated by our Server Health team and they are working to resolve the issue as soon as possible.

We sincerely apologize for the inconvenience that this has caused.

Thank you for your patience and cooperation in regards to troubleshooting this issue. We will post further updates on this page until the issue is resolved.