17th November 2021

HostPapa Dashboard HP Dashboard and Ticketing System Issues

FIXED: Nov/17/2021 05:10 AM EST

The issue with Dashboard has been fixed. Access to accounts should be working now. If you are still experiencing any issues, feel free to contact our Support team anytime, https://www.hostpapa.com/about-hostpapa/contact/

We appreciate your patience in this matter.


INVESTIGATING: Nov/17/2021 05:00 AM EST

We are experiencing some issues with accessibility on our Dashboard. This is being looked into and our System engineers are working to resolve it immediately.

More updates will be posted as they are available. Sorry for the inconvenience and thank you for your understanding.