23rd November 2021

Web Hosting HP310 - Server Load Issues

FIXED: Nov/23/2021 03:30 PM EST

Our Server Engineers have applied a fix and services should be accessible again. We are currently monitoring the stability of the server at this time.

If you are still experiencing any errors with your services, please contact our Support team through Live Chat, Phone, or Email [email protected]

Thank you for your patience and understanding in this matter.


INVESTIGATING: Nov/23/2021 03:00 PM EST

We are experiencing high load issues that may affect the ability of clients to access websites and email on server hp310.

This is being investigated by our Server Health team, and they are working to resolve the issue as soon as possible.

We sincerely apologize for the inconvenience that this has caused.

Thank you for your patience and cooperation regarding troubleshooting this issue. We will post further updates on this page until the issue is resolved.