14th October 2019

Web Hosting HP295 Performance Issues

FIXED (03:30 AM EST) - Our monitoring on the server is showing that load is now stable, and sites are loading without issues. This is now fixed, but if you are still experiencing issues or have any other concerns or questions, please do reach out to our 24/7 support, via Phone, Live Chat or Emails:

https://www.hostpapa.com/about-hostpapa/contact/

MONITORING (03:02 AM EST) - A fix to the reported performance issues have been implemented by our Server Health Team, and we are currently monitoring the server load as well as performance of sites hosted in the server.

INVESTIGATING (02:36 EST) - Our server health team is currently investigating a performance issue affecting the hp295 shared server. This affects Websites & Emails hosted under the server. Similar issues are not detected on any other servers in our fleet at the moment.

Updates will be posted as soon as they come in. We sincerely apologize for the inconveniences caused.