16th October 2019

Web Hosting Performance issues - hp295 server

Update (9:55am EST)

The server is now under normal loading, sites and email should be loading normally.

Further tests are still being performed to confirm if the issue is fully resolved, by our system administrators. Once fully confirmed, case will be closed at that time.

Update (8:13am EST)

Our team managed to stabilize the server and it is currently being monitored. Next updates will be posted once our system administrators will confirm the load issues are resolved permanently.

Thank you for your continued patience.

7:20am EST

hp295 shared server is experiencing intermittent load issues. Our Server Health team is actively working on the server to stabilize it.

We are sorry for the inconvenience caused. Updates will be posted once available.