28th October 2019

HostPapa Dashboard HostPapa Dashboard access issues

Update 12:00 EST:

Our Engineering team has resolved the issue with our HostPapa Dashboard, and access to the portal should be operating normally. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.


Update 11:30 EST:

Our Engineering team has implemented a fix to resolve the issue with our HostPapa Dashboard and is monitoring the situation. We will post an update as soon as we will confirm that the issue is fully resolved.


Our Engineering team is investigating an issue with our HostPapa Dashboard. During this time, users may experience issues accessing the HostPapa Dashboard. We apologize for the inconvenience and will share an update once we have more information. We are actively working on a fix.