28th November 2019

AU - Credit Card Payment Issue

UPDATE: 28/11/2019 - 07:47 PM EST A fix for this has now been deployed and our testing shows that credit card payment in AU is now working normally, but we are watching the issue closely to ensure resolution. Please reach out to our Support via Live Chat, Phone or Email, if you are still encountering issues when making credit card payment.

UPDATE: 10:35 AM EST We're continuing to investigate the root cause of this issue, however it is still impacting our ability to process credit card payments from AU brand. Pricing campaigns have been paused for AU brand at this time, until the issue is resolved.


INVESTIGATING: 06:35 AM EST We are currently experiencing issues processing credit card payments for clients using AU (Australia Branded) accounts.

Our team is currently investigating the problem and updates will be posted here regarding the issue. We're sorry for the inconvenience this is causing at this time and are working to correct it as soon as possible.