9th December 2019

Basic Email PapaMail: Problem with Webmail

We are investigating reports of service degradation with our PapaMail service. Some customers may be unable to access their inbox via Webmail at this time. Our Operations team is working on resolving the issue as soon as possible! We will post details as we receive.


UPDATE - 01:50 PM EST

Our operations team have identified a fix and they are working through reindexing affected users. We will continue to provide updates on the progress.


UPDATE - 04:50 PM EST

Our operations team has resolved the issue by re indexing the affected users. Thank you for your patience while we worked to resolve the problem.

We apologize for the issues this might have caused to you. Thanks for your patience and understanding.