23rd December 2019

Basic Email Scheduled Maintenance: Basic and Advanced Email (PapaMail)

Update 20:09 EST

The scheduled maintenance has been completed. Thank you for your understanding and we apologize for any inconveniences caused. Please do reach out if you are experiencing any issues related to Hostpapa Basic/Advanced Email.


Update 18:55 EST

Scheduled maintenance is currently in progress. We will provide updates as necessary.


We will be performing some emergency maintenance on Cluster A

Client Impact: Some users on Cluster A my experience two brief disconnects and re-connects during this maintenance period.

Start time Dec 23, 18:55 ET

Estimated duration 1 hour and 5 minutes

We apologize for any inconveniences this may cause to you!