14th January 2020

Web Hosting Issue with Outgoing Email in some servers: max defers per hour (5/5)

Update: 16/01/2020 06:40 AM EST The issue has been resolved.

Update: 15/01/2020 10:00 AM EST Our team is implementing a fix and improvements should be seen shortly. We’ll post updates once the issue is permanently fixed.

Thank you for your patience and cooperation.

Update: 14/01/2020 6:30 AM EST We identified cause of the issue and are working on the solution.

We have acknowledged an issue impacting several customers, affecting the Outgoing email delivery with the bounce-back message: max defers per hour (5/5). This affects both Webmail and Email Client connections.

We are currently deploying a fix for all servers being affected by this.

We appreciate your patience and understanding as we resolve this for everyone.