27th February 2020

WebSite Builder Publishing Issue

Update: 8:35 AM EST

The issue has since been resolved. If you continue to experience any issues while attempting to publish your site from inside Web Site Builder please contact our support.

Update: 8:05 AM EST

A fix has been implemented and we're testing at this time.

Start: 3:15 AM EST

Some users may receive an error when attempting to Publish from WebSite Builder.

There is a known issue that our technicians are investigating at this time to resolve the issue as soon as possible.

We're sorry for any inconvenience this may cause. We will update this page with further updates on the issue. Thank you for your patience and cooperation.