SMTP error - Mailchannel Friday 3rd November 2023 17:08:33


IDENTIFIED: Nov/03/2023 - 5:00 PM EST

Our Engineering team identified an issue with mailchannel where customers are getting this error:

SMTP error from remote mail server after end of data: 550 5.7.1 [ESA] Sender blocked.

We are currently working on the issue and looking for a permanent fix.

We sincerely apologize for the inconvenience this might be causing on your side.

We will post further updates once available.

COMPLETED: Nov/03/2023 - 5:50 PM EST

The issue encountered with the temporary SMTP block was fixed and is working as expected.

We sincerely apologize for the issues caused.

If you still have any issues, do not hesitate to reach our support via Live Chat, Phone, or Email.

Thanks for your patience and comprehension.