Papamail Issue Detected Monday 27th November 2023 18:11:00


RESOLVED: Nov/28/2023 - 01:30 AM EST

The Papamail services are fully operational. Rest assured, our Engineering Team is still closely monitoring the server to ensure stability.

Should you continue to have any issues, please contact our support team via LiveChat, Phone, or Email/Support Ticket.

You can find all our contact info at www.hostpapa.com/about-hostpapa/contact.


INVESTIGATING - NOV/27/2023 - 6:10 PM EST

We are investigating an issue preventing some users on one of our Cluster A mailstores from logging into Webmail. Our engineering team has been engaged. We will provide an update once we have additional information.