Papamail Advanced/Basic Issues Detected Sunday 21st January 2024 20:34:50


INVESTIGATING - JAN/22/2024 -7:46 PM EST

We are currently experiencing an incident that is impacting Papamail Advanced/Basic, (IMAP, POP, Webmail).

We have been made aware that users are unable to receive emails currently.

Our Hosted Email engineerings are investigating and we will update you shortly

RESOLVED

The Papamail services are fully operational. Rest assured, our Engineering Team is still closely monitoring the server to ensure stability.

Should you continue to have any issues, please contact our support team via LiveChat, Phone, or Email/Support Ticket.

You can find all our contact info at www.hostpapa.com/about-hostpapa/contact.