HP 301 - Performance Issues Tuesday 14th April 2020 20:41:00


-- UPDATE 12:18 AM EST --

Update: The server is now stable and performing normally. Thank you for your patience, and we sincerely apologize for any inconveniences caused. Please do reach out to our Support via Live Chat or Phones, if you're still experiencing any issues or have any concerns.


-- UPDATE 10:30 PM EST --

Fixes have been applied, and we are seeing improvements to the performance of HP301. We're monitoring this closely still, and will update this incident accordingly.


Our Server Health team is currently investigating into performance issues affecting one of our shared server, HP301.

We apologize for the inconvenience and will share an update once we have more information.