Basic/Advanced Email Maintenance Tuesday 28th April 2020 00:05:00


-- UPDATE 2:10 AM EST --

The scheduled maintenance has been completed. Please don't hesitate to reach out to support should you require further assistance, or have any questions about this.


-- UPDATE 1:11 AM EST --

Scheduled maintenance is currently in progress. We will provide updates as necessary.


Basic/Advanced Email service will be undergoing a brief maintenance in 60 minutes. Short windows of downtime are expected (1-2 minutes). You may also encounter brief interruptions in service and connectivity.