Papamail Advanced/Basic Issues Detected Tuesday 20th February 2024 11:24:38


INVESTIGATING - FEB/20/2024 - 11:20 AM EST

We are currently experiencing inbound mail delays, slowness, and IMAP failures on Cluster A. Our engineering team is investigating the issue.

We will provide an update once we have additional information.

RESOLVED - FEB/20/2024 - 12:40 PM EST

This incident has been resolved by our engineering team.

We apologize for any inconvenience caused due to this problem.

If you encounter any issue on your side, do not hesitate to reach out to our Support Team.