Papamail Advanced/Basic Login Issues Detected Thursday 22nd February 2024 10:35:48


INVESTIGATING - FEB/22/2024 - 10:35 AM EST

We are investigating an issue preventing some users on Cluster A from logging into Webmail. Our engineering team has been engaged.

We will provide an update once we have additional information.

RESOLVED: FEB/22/2024 - 12:00 PM EST

Our engineers have been able to resolve the issue affecting Cluster A Webmail. This incident is now resolved.

We apologize for any inconvenience caused and are here if you need additional assistance with your Papamail.