HP304 - Emergency Maintenance Sunday 25th February 2024 03:10:00


EMERGENCY MAINTENANCE: FEB/25/2024 - 03:10 AM EST

Server HP304 is having maintenance performed on it, and as such services located on this server may be affected and become inaccessible.

We sincerely apologize for any inconvenience caused.

UPDATE: FEB/25/2024 - 09:50 AM EST

The server is still experiencing issues intermittently and our System Admins are continuously working on a permanent fix. They will continue to monitor the server to make sure that it is fully resolved and functional.

We sincerely apologize for the inconvenience and we appreciate your patience in this matter.

RESOLVED: FEB/25/2024 - 2:30 PM EST

The emergency maintenance has been completed and the server HP304 is back online. We are still monitoring to ensure stability.

Should you continue to have any issues, please contact our support team via LiveChat, Phone, or Email/Support Ticket.

You can find all our contact info at www.hostpapa.com/about-hostpapa/contact.