LiveChat System is experiencing issues Tuesday 27th February 2024 11:29:38


INVESTIGATING: Feb/27/2024 - 11:25 AM EST

Our LiveChat system is currently experiencing some issues and you may be unable to use it properly now. We're investigating this currently and further updates will be provided here.

You can still reach us by phone or support ticket/email. Thank you for your patience and cooperation.

RESOLVED - Feb/27/2024 - 2:40 PM EST

After the issue was identified, our engineers implemented a fix and monitored it for a few hours.

We're glad to inform you that the issue has been fixed and LiveChat is functional again.

Thanks for your patience and understanding during this time.