LiveChat Support is Unavailable Tuesday 9th June 2020 18:05:00


RESOLVED 09:15 PM EST

The issue with our Live Chat Support has been resolved.

We are sorry for the inconvenience and we appreciate your patience in this matter.


MONITORING

A fix has been implemented and you should be able to reach us through our Live Chat support.

We are still monitoring the issue and we will keep you updated until it is fully resolved.

We're sorry for the inconvenience.


INVESTIGATING

Our LiveChat support is down at the moment. You may be able to access it, but we can not answer the chats properly.

This is being investigated, and we will update this status page periodically until resolved.

We're sorry for the inconvenience. You can still contact support via our ticket system, by email and via our phone lines.