Backup Service Interruption Thursday 7th March 2024 15:06:00


COMPLETED: MAR/08/2024 - 06:00 AM EST

The emergency maintenance has been completed and Backup Service is operating normally again after closely monitoring it.

Should you continue to have any issues, please contact our support team via LiveChat, Phone, or Email/Support Ticket. You can find all our contact info at www.hostpapa.com/about-hostpapa/contact.


IDENTIFIED: Mar/07/2024 - 3:00 PM EST

We are currently experiencing an issue with our backup services. This issue affects backup access, particularly for our dedicated customers paying for this service.

Our team is aware of the issue and is working diligently to resolve it. At this time, backups in the Los Angeles region are unavailable. We understand the importance of these backups to our dedicated customers and apologize for any inconvenience this may cause.

We are investigating the cause of this issue and are working to restore service as quickly as possible. We will provide updates on our progress as more information becomes available.

Thank you for your patience and understanding.