Papamail - Webmail Login Issue Thursday 25th April 2024 12:24:00


INVESTIGATING - Apr/25/2024 - 12:20 PM EDT

We're currently experiencing issues with webmail on Cluster A being slow/unresponsive, also impacting login.

We are investigating this issue and will post updates as they become available.

RESOLVED: APR/25/2024 - 10:00 PM EST

Our Engineers were able to find the cause of the slowness in Cluster A webmail and rectify it. Service is once again working as expected.

Should you continue to have any issues, please contact our support team via LiveChat, Phone, or Email/Support Ticket.

You can find all our contact info at www.hostpapa.com/about-hostpapa/contact.

UPDATE - Apr/25/2024 - 6:00 PM EDT

The investigation continues for the Cluster A webmail slow and unresponsiveness.

Further updates to come.

UPDATE - Apr/25/2024 - 3:15 PM EDT

We are still investigating this issue. We will provide further updates on our status page as soon as new information becomes available.

Thank you for your patience and understanding.